Platform Slowness

Incident Report for LogiNext

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 15:00 EST

Investigating

We are investigating the issue
Posted Jan 27, 2026 - 12:55 EST
This incident affected: LogiNext Platform.